:::

17. 升級XOOPS

一、搬移後的檢查

  1. 先用phpMyAdmin開啟除錯,順便檢查資料庫是否有完整資料表。
  2. 比對modules中有沒有少模組?
  3. xoops_data是否有開放寫入權限(含底下所有子目錄)
  4. mainfile.php的設定是否正確?

二、升級前環境檢查及備份

  1. 檢查系統可以升級到哪一個版本,若不曉得,可自製phpinfo.php來檢測。
    • (1) XOOPS 2.5需要PHP 5.2以上,MySQL 5.0 以上
    • (2) XOOPS 2.3.x~ 2.4.x需要PHP 4.3以上,MySQL 3.2 以上
    • (3) 相簿需要PHP有支援exif
  2. FTP不太需要備份,SQL可順手備份一下。

三、XOOPS 升級

  1. 先將網站關閉,清空session表,強制線上用戶登出。
  2. 下載XOOPS 2.5,解壓,並將 upgrade 目錄整個上傳到網頁目錄下。
  3. 刪掉xoops2.5中 htdocs下的mainfile.php、install、cache、template_c、 uploads、themes(若是使用內建佈景,並且有做了修改才需要刪除)
  4. 刪掉舊主機中的 /modules/system 模組(避免一些不必要的檔案存在)
  5. 將 xoops2.5中 htdocs下的所有檔案上傳,並全部覆蓋。
  6. 將xoops_data及xoops_lib移出網頁目錄之外
  7. 確定xoops_data(含底下所有目錄)、mainfile.php 及 /include/license.php 設為777(可寫入)
  8. 開啟mainfile.php刪掉防護模組的 Pre-check 及 Post-check 設定(若有的話)
    include XOOPS_TRUST_PATH.'/modules/protector/include/precheck.inc.php' ;
    include XOOPS_TRUST_PATH.'/modules/protector/include/postcheck.inc.php' ;
  9. 用瀏覽器執行「http://網址/upgrade」進行資料庫升級。升級後,刪除該目錄。
  10. 將mainfile.php重設為444
  11. 到後台更新「system系統」、「Profile會員管理」、「Protector防護」等模組。

四、若是從XOOPS 2.0.13之前的升級

升級後刪除 class/smarty/core、class/smarty/plugins/resource.db.php

五、若更新後出現:Fatal error: Call to...configitem.php on line 367

那表示您的 /xoops_data/data/secure.php 這個檔不存在或沒內容。請參考下面內容,自行修改,並存成secure.php即可。

<?php
define('XOOPS_DB_TYPE', 'mysql');
if (defined("XOOPS_DB_CHARSET")) die('Restricted Access');
define('XOOPS_DB_CHARSET', 'utf8');
define('XOOPS_DB_PREFIX', '資料表前置字串');
define('XOOPS_DB_HOST', 'localhost');
define('XOOPS_DB_USER', '資料庫帳號');
define('XOOPS_DB_PASS', '資料庫密碼');
define('XOOPS_DB_NAME', '資料庫名稱');
define('XOOPS_DB_PCONNECT', 0);
?>

六、用FireBug來調整檢查畫面

  1. 在fireFox瀏覽器中可安裝FireBug外掛套件,以利版面檢查調整。
  2. 點選下方螢火蟲圖示,點選藍色小方框,點選畫面上要修改的部份。

 補充:tad_menu用法,請於佈景 theme.html適當位置加上:<{insert name='tad_menu'}>


:::

搜尋

QR Code 區塊

https%3A%2F%2Fwww.tad0616.net%2Fmodules%2Ftad_book3%2Fpage.php%3Ftbsn%3D13%26tbdsn%3D393

書籍目錄

展開 | 闔起

線上使用者

59人線上 (39人在瀏覽線上書籍)

會員: 0

訪客: 59

更多…