:::
建議 tad - Tad 碎碎念... | 2016-10-21 | 人氣:8987

嗯...因為facebook的API不斷更新,所以,利用facebook登入的方法也必須隨支調整,否則到十月底可能就無法使用了,因此,在前兩天有重新改寫了 tad_login 中 facebook 快速登入的部份。

由於變動蠻大的,所以,預期更新後應該會有哀鴻遍野的狀況...

首先,如果您的 PHP 是 5.4 以下的,也就是 5.3.x 或更舊的,那麼,建議您,直接到 tad_login 的偏好設定,先取消 facebook 就好,因為PHP版本太舊是沒救的,網站就直接死給你看,facebook官網提供的SDK至少就是 PHP 5.4 起跳。

如果您的 PHP 是5.4以上,那恭喜您,只要確定也有更新到tadtool最新版,接著只要到 https://developers.facebook.com/apps 去,照著後台說明重設一下就好(補一些缺少的資料)。

如果您的 Facebook API 是2.1或 2.2 的(從FB的主控台就看得到),那建議您直接刪除該應用,接著照著後台說明重設一個新的,因為從 2.1是無法升級到新的版的API的

取得新的編號及密鑰後,到XOOPS的tad_login後台編號設定重新輸入編號及密鑰,這樣就一勞永逸啦~不...應該說至少可以撐個幾年吧。

如果您的主機 PHP 是 5.4 以下,但又非得用 facebook 登入不可的話,那麼,請移除最新版 tad_login,然後至 http://120.115.2.90/modules/tad_modules/index.php?module_sn=24 下載 4.2版,自己解壓縮手動上傳安裝即可。只是能用到什麼時候,我就不敢確定啦!

 

 

網友個人意見,不代表本站立場,對於發言內容,由發表者自負責任。
:::

訂閱 / 取消電子報

目前訂閱人數: 955 人

線上使用者

6人線上 (2人在瀏覽最新消息)

會員: 0

訪客: 6

更多…

網站佈景


(共 5 個樣板佈景)